Disruptions on 3D Secure authentication

Incident Report for Pachira Pay

Resolved

This incident has been resolved.
Posted Apr 23, 2023 - 17:53 CEST

Identified

Nous constatons des perturbations sur l'authentification 3D Secure. Nous vous tiendrons informés lorsque nous aurons plus d'informations à ce sujet.
-----------
We are currently experiencing disruptions on 3D Secure authentication. We will reach you as soon as we have more information.
Posted Apr 23, 2023 - 17:25 CEST
This incident affected: 3D Secure.