Disruptions on 3D Secure enrollment

Incident Report for Pachira Pay

Resolved

This incident has been resolved.
Posted Nov 17, 2023 - 02:08 CET

Update

We are continuing to work on a fix for this issue.
Posted Nov 17, 2023 - 02:07 CET

Identified

Nous constatons des perturbations sur l'enrolement 3D Secure. Nous vous tiendrons informés lorsque nous aurons plus d'informations à ce sujet.
-----------
We are currently experiencing disruptions on 3D Secure enrollment. We will reach you as soon as we have more information.
Posted Nov 16, 2023 - 23:30 CET
This incident affected: 3D Secure.