3DS Perturbations

Incident Report for Pachira Pay

Resolved

This incident has been resolved.
Posted Nov 29, 2023 - 18:11 CET

Identified

There is an ongoing 3D Secure incident. Impacted banks are Credit Mutuel, Banque Populaire and Caisse d'Epargne.
Posted Nov 29, 2023 - 18:00 CET
This incident affected: 3D Secure.